Ошибка при обновлении дистрибутива LTS

Обновляем убунту до нового LTS релиза:

do-release-upgrade

На выходе получаем ошибку:

Please install all available updates for your release before upgrading.

Первый способ:

sudo apt-get update
sudo apt-get upgrade -y
sudo apt-get dist-upgrade
sudo do-release-upgrade

Если вдруг не помогло, как мне, тогда второй способ.

sudo apt-get update

 

Вот и ошибка в самом низу
sudo apt list --upgradable

 

Поиск вредителя

А вот и проблема из-за которой я не мог обновиться. Осталось просто удалить ее:

sudo apt remove opera-stable

Вот и все. Обновляемся 🙂